$re = '/^(?!.*\bbadword\b).{25,}$/s';
$str = 'Some string that is long enough to contain 25 chars and no badwordd.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);