$re = '/\s*\b\d+\b\s*/';
$str = '0 I64 EB MM 93
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;