package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(*NO_AUTO_POSSESS)\w+:`)
var str = `get accept:`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}