package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\s]?\#?[\s]?somevalue[\s]?.*$`)
var str = `somevalue
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}