using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http://[^/]+\/tempfiles/(?:[^/]+\/)*\w+\.jpg";
string input = @"blah blah <img src=http://somelink/file.html>http://server/tempfiles/blah.jpg
blah blah";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}