import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+)(?:\\s{5,}|$)";
final String string = "Глава девятая\n"
+ "ПЛАВУЧИЙ ДОМ\n"
+ " \n\n"
+ " Мне захотелось еще раз пойти взглянуть на одно место, которое я приметил посредине острова, когда его осматривал; вот мы с Джимом и отправились и скоро туда добрались, потому что остров был всего в три мили длиной и в четверть мили шириной.\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n"
+ " Не успели мы добраться до нижнего конца острова, как начало светать. Мы заглянули в окно. Мы разглядели кровать, стол, два старых стула, и еще на полу валялось много разных вещей, а на стене висела одежда. В дальнем углу лежало что-то вроде человека. Джим окликнул:\n"
+ " — Эй, ты!\n"
+ " Но тот не пошевельнулся. Тогда и я тоже окликнул его. А потом Джим сказал:\n"
+ " — Он не спит — он мертвый. Ты не ходи, я сам пойду погляжу.\n"
+ " Он влез в окно, подошел к лежащему человеку, нагнулся, поглядел и говорит:\n"
+ " — Это мертвец. Да еще к тому же и голый. Его застрелили сзади. Должно быть, дня два или три, как он умер. Поди сюда, Гек, только не смотри ему в лицо — уж очень страшно.\n"
+ " Я совсем не стал на него смотреть. Джим прикрыл его каким-то старым тряпьем, только это было ни к чему: я и глядеть-то на него не хотел. На полу валялись старые, замасленные карты, пустые бутылки из под виски и еще две маски из черною сукна, а все стены были сплошь исписаны самыми скверными словами и разрисованы углем. На стене висели два заношенных ситцевых платья, соломенная шляпка, какие-то юбки и рубашки и мужская одежда. Мы много кое-чего снесли в челнок — могло пригодиться. На полу валялась старая соломенная шляпа, какие носят мальчишки; я ее тоже захватил. А еще там лежала бутылка из-под молока, заткнутая тряпкой, чтоб ребенку сосать. Мы бы взяли бутылку, да только она была разбита. Были еще обшарпанный старый сундук и чемодан со сломанными застежками, и тот и другой стояли раскрытые, но ничего стоящего в них не осталось. По тому, как были разбросаны вещи, видно было, что хозяева убежали второпях и не могли унести с собой все пожитки.\n"
+ " Нам достались: старый жестяной фонарь, большой нож без ручки, новенький карманный ножик фирмы Барлоу (такой ножик ни в одной лавке не купишь дешевле, чем за полдоллара), много сальных свечей, жестяной подсвечник, фляжка, жестяная кружка, рваное ватное одеяло, дамская сумочка с иголками, булавками, нитками, куском воска, пуговицами и прочей чепухой, топорик и гвозди, удочка потолще моего мизинца, с большущими крючками, свернутая в трубку оленья шкура, собачий ошейник, подкова, пузырьки из-под лекарств, без ярлыков; а когда мы собрались уже уходить, я нашел довольно приличную скребницу, а Джим — старый смычок от скрипки и деревянную ногу. Ремни вот только оторвались, а так совсем хорошая нога, разве только что мне она была длинна, а Джиму коротка. А другую ногу мы так и не нашли, сколько не искали.\n"
+ " Так что, вообще говоря, улов был неплохой. Когда мы собрались отчаливать от дома, совсем уже рассвело. Мы были на четверть мили ниже острова; я велел Джиму лечь на дно челнока и прикрыл его ватным одеялом, — а то, если б он сидел, издали было бы видно, что это негр. Я стал править к иллинойскому берегу с таким расчетом, чтобы нас отнесло на полмили вниз по течению, потом держался под самым берегом, в полосе стоячей воды. Мы вернулись на остров без всяких приключений, никого не повстречав.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}