$re = '/^(?:(?:[1-9]|1[0-2])(?:,|$)){0,12}$/m';
$str = '1,2,3
1,02,3
1,2,3,
1,2,,3
,1,2,3
1,2,3,4,5,6,7,8,9,10,11,12
1,2,3,4,5,6,7,8,9,10,11,12,1
1,2,3,4,5,6,7,8,9,12
1,2,3,4,5,6,7,8,9,13
12,11,10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);