import re
regex = re.compile(r"(\/{1}[a-z.0-9]+\/{1}$)|([0-9]+$)", flags=re.MULTILINE)
test_str = ("https://www.facebook.com/j2teamnnl/\n"
"https://www.facebook.com/groups/j2team.community/\n"
"https://www.facebook.com/profile.php?id=100048240755558\n"
"h//www.facebook.com/\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")