$re = '/^(?=.*[a-zA-Z])([^#$%^&*()\=\[\]{};\':"\\\\|,.<>\/?]){6,60}$/';
$str = 'l4@-+_';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);