#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*@softcomputer\.com>? *(?:"? *<\S+>)?$"
Local $sString = "== Real scc" & @CRLF & _
"Mary Bills <marybil@softcomputer.com>" & @CRLF & _
" <ellie@softcomputer.com>" & @CRLF & _
" <thereasaw@softcomputer.com>" & @CRLF & _
"test@softcomputer.com" & @CRLF & _
"<test@softcomputer.com>" & @CRLF & _
"olexiyry@softcomputer.com <olexiyry@softcomputer.com>" & @CRLF & _
"Deseriee Harkins <deseriee@softcomputer.com>" & @CRLF & _
"" & @CRLF & _
"== Forged scc" & @CRLF & _
"Dorota Mazurek <dorotam@softcomputer.com> <reservations@nesthotel.com>" & @CRLF & _
"Nikki Taft <nicolet@softcomputer.com> <Muhammad.owais@abtach.com>" & @CRLF & _
"Lynette Didia <ldidia@softcomputer.com> <Muhammad.owais@abtach.com>" & @CRLF & _
"Dorota Mazurek <dorotam@softcomputer.com> <centralbookings@kbcsa.co.za>" & @CRLF & _
"Jeffrey Marr <jeffreym@softcomputer.com> <srvadv5.blr@vw-ppsmotors.co.in>" & @CRLF & _
"Iryna Dmytriyeva @SCC <idmy@softcomputer.com> <sc@grupoinrexsa.com>" & @CRLF & _
"Vickie Nix vickieh@softcomputer.com <m.recovery@albarondebt.com>" & @CRLF & _
"Bill Young <billyo@softcomputer.com> <sara@eaurenaissance.com>" & @CRLF & _
"" & @CRLF & _
"== Questionable" & @CRLF & _
""Kurt Veith <kurtv@softcomputer.com>" <marlene.robles@mld.com.mx>" & @CRLF & _
""softcomputer.com" <MAIL.QUOTA@servers.com>" & @CRLF & _
""marksm@softcomputer.com" <mark560sl@gmail.com>" & @CRLF & _
"" & @CRLF & _
"== Valid non-forged addresses" & @CRLF & _
""sarahze@softcomputer.com via Smartsheet" <user@smartsheet.com>" & @CRLF & _
""yuvi softcomputer.com" <hugginshospital.notification@zixmessagecenter.com>" & @CRLF & _
"<technicalsupport@softcomputer.com.au>" & @CRLF & _
""Secure Email From yevgeny@softcomputer.com via Message Pickup Center" <emx-intermedia@securemail.intermedia.net>" & @CRLF & _
""Secure Email From yevgeny@softcomputer.com via Message Pickup Center" <emx-intermedia@securemail.intermedia.net>" & @CRLF & _
""mpettis@softcomputer.com via SurveyMonkey" <member@surveymonkeyuser.com>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")