using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*Azure\s+v(.*?)\s+.*";
string substitution = @"\1";
string input = @"N/A 9.0 Yes Yes N/A N/A N/A N/A 8.8 Yes Yes N/A N/A N/A N/A 8.7 Yes Yes N/A N/A N/A N/A 9.2 Yes Yes Yes Yes Yes Yes 9.1 Yes Yes Yes Yes Yes Yes 9.0 Yes Yes Yes Yes Yes Yes 8.8 Yes Yes Yes Yes Yes Yes 8.7 Yes Yes Yes Yes Yes Yes 22.04 Yes Yes Yes Yes Yes Yes AKS Microsoft Azure v1.27 EKS Amazon v1.27 Amazon Linux 2 is certified";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}