$re = '/\bprecision\s+highp\s+float(*SKIP)(?!)|highp\s+float/m';
$str = ' precision highp float;
highp float intensity;';
$subst = "lowp float";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;