$re = '/\s*const\s+(.*)\b[^}]*((}\n)|(}))/';
$str = ' const name = () => {}
const age = () => {}
const height = () => {}
const location = () => {}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);