re = /(0|\+98)?([ ]|-|[()]){0,2}9[1|2|3|4]([ ]|-|[()]){0,2}(?:[0-9]([ ]|-|[()]){0,2}){7}/
str = '+98935123456
0935123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end