#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\[)([^[]*)(?=\|)\|\1(?=\])"
Local $sString = "==///Listings==/?" & @CRLF & _
"assadsadsadsa" & @CRLF & _
"adasdsad" & @CRLF & _
"</test>" & @CRLF & _
"''[[excellent wheat|excellent wheat]]''" & @CRLF & _
"''[[brilliant corn|Tom's brilliant corn]]''" & @CRLF & _
"</separation>" & @CRLF & _
"Remember to purchase this if on offer" & @CRLF & _
"''[[jub|jub/ha]]''," & @CRLF & _
"''[[barley|barley/hops]]''" & @CRLF & _
"zcxcxzcxz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")