const regex = /^(BSR_+[0-9]{4}(0[1-9]|1[0-2])(0[1-9]|[1-2][0-9]|3[0-1])[T](2[0-3]|[01][0-9])[0-5][0-9][0-5][0-9])+(.csv)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(BSR_+[0-9]{4}(0[1-9]|1[0-2])(0[1-9]|[1-2][0-9]|3[0-1])[T](2[0-3]|[01][0-9])[0-5][0-9][0-5][0-9])+(.csv)$', 'gm')
const str = `BSR_20190228T030404.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}