import re
regex = re.compile(r"(None|NaN?|[-\d]+)?(.*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("2020-10-2125Chavez and Sons\n"
"2020-05-02Bean Inc\n"
"NaNRobinson, Mcmahon and Atkins\n"
"2020-04-25Hill-Fisher\n"
"2020-04-02Nothing and Sons\n"
"52457Carpenter and Sons\n"
"0Carpenter and Sons\n"
"Carpenter and Sons\n"
"NoneEconomy and Sons\n"
"NoNeEconomy and Sons\n"
"2020-04-02\n"
"NAEconomy and Sons")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")