package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(?:facebook\.com|fb\.me).*$`)
var str = `facebook.com
fb.me
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}