$re = '/^(?!(^0\d).)^\d*\.?\d+$/m';
$str = '012345
123455
.0123
0.0234
123.1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);