const regex = new RegExp('(?:^|\\s)(?=\\S*[^\\u0000-\\u007FáéíóúüñÁÉÍÓÚÜÑ¿¡])\\S+', 'gm')
const str = `aveces soñar es muy ließ y también человек`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);