$re = '/System Message: (?<agent>\w+) is ready to chat.*?[\r\n]+[\d\/]+\s+[\d:]+\s+\w+\s+[\r\n]+(?P=agent)[\r\n]+(?<agentFirstResponse>.*?)[\r\n]+[\d\/]+\s+[\d:]+\s+\w+/ms';
$str = '1/1/2019 2:42:55 AM
Aju
Hi Team
1/1/2019 2:42:56 AM
System
The data has been added:
- Customer Info
1/1/2019 2:42:59 AM
Rohi
System Message: Rohi is ready to chat.
1/1/2019 2:43:09 AM
Aju
Wish you a very happy ne year
1/1/2019 2:43:12 AM
Aju
new*
1/1/2019 2:43:25 AM
Aju
I need to KNOW ABOUT A CAR
1/1/2019 2:43:32 AM
Aju
please help me
1/1/2019 2:45:07 AM
Aju
Anyone there ?
1/1/2019 2:47:13 AM
Aju
??
1/1/2019 2:49:23 AM
Aju
?? Hi Rohi You there?
1/1/2019 2:51:16 AM
Rohi
Hello Aju my name is Rohi. How can I help you today?
1/1/2019 2:51:27 AM
Chat goes on....';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);