$re = '/((.){2,4}).(\1|\2)/m';
$str = 'abab abcc
abcababca
bbaaaabb
abcdabdc
abcbacabcac';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);