import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((iPhone([\\d\\W]+)|iPhone|iPad)(;|\\s\\d+;|\\s\\w+;|\\s\\d+\\w+;)?(\\s+)?(U;)?)(\\s+)?(CPU|iOS)([^\\);]+)?)";
final String string = "RubyBrowser/46.3.26 (iPhone; iOS 15.0.2; Scale/2.00)\n"
+ "bazaart/7.4.3 (iPhone; iOS 15.0.2; Scale/2.00)\n"
+ "Mozilla/5.0 (iPhone; CPU iPhone OS 13_5_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148 LightSpeed [FBAN/MessengerLiteForiOS;FBAV/294.0.0.60.128;FBBV/262406393;FBDV/iPhone11,8;FBMD/iPhone;FBSN/iOS;FBSV/13.5.1;FBSS/2;FBCR/;FBID/phone;FBLC/en;FBOP/0]\n"
+ "Mozilla/5.0 (iPhone; CPU iPhone OS 14_7_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148 LightSpeed [FBAN/MessengerLiteForiOS;FBAV/332.0.0.45.117;FBBV/321367341;FBDV/iPhone11,2;FBMD/iPhone;FBSN/iOS;FBSV/14.7.1;FBSS/3;FBCR/;FBID/phone;FBLC/en;FBOP/0]\n"
+ " 120572 Mozilla/5.0 (iPhone1 03; CPU iPhone OS 11_0_1 like Mac OS X) AppleWebKit/604.3.5 (KHTML, like Gecko) Version/11.0 MQQBrowser/8.2.1 Mobile/15B87 Safari/604.1 MttCustomUA/2 QBWebViewType/1 WKType/1\n"
+ " 120584 OneDriveiOSApp/12.19.5 (iOS/14.4; en_CA; Apple/iPhone)\n"
+ " 120613 Mozilla/5.0 (iPhone X; CPU iPhone OS 13_4 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1 Mobile/15E148 Safari/604.1\n"
+ " 120690 Instagram 175.0.0.23.117 (iPhone8,1; iOS 14_1; de_DE; de-DE; scale=2.00; 750x1334; 272995447) AppleWebKit/420+\n"
+ " 120696 Instagram 175.0.0.23.117 (iPhone13,1; iOS 14_2_1; it_IT; it-IT; scale=2.88; 1080x2338; 272995447) AppleWebKit/420+\n"
+ " 120697 Instagram 174.0.0.21.119 (iPhone12,3; iOS 13_6; it_IT; it-IT; scale=3.00; 1125x2436; 271836321) AppleWebKit/420+\n"
+ "Mozilla/5.0 (iPad; CPU OS 8_4_1 like Mac OS X) AppleWebKit/600.1.4 (KHTML, like Gecko) Version/8.0 Mobile/12H321 Safari/600.1.4\n"
+ "Mozilla/5.0 (iPad; CPU OS 10_3_3 like Mac OS X) AppleWebKit/600.1.4 (KHTML, like Gecko) GSA/7.0.55539 Mobile/14G60 Safari/600.1.4\n"
+ "Mozilla/5.0 (iPad; CPU OS 10_3_2 like Mac OS X) AppleWebKit/603.2.4 (KHTML, like Gecko) Version/10.0 Mobile/14F8089 Safari/602.1\n"
+ "Mozilla/5.0 (iPad; CPU OS 10_3_3 like Mac OS X) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.0 Mobile/14G60 Safari/602.1\n"
+ "Mozilla/5.0 (iPad; CPU OS 9_3_2 like Mac OS X) AppleWebKit/601.1 (KHTML, like Gecko) CriOS/63.0.3239.73 Mobile/13F69 Safari/601.1.46\n"
+ "Mozilla/5.0 (iPad; CPU OS 9_3_2 like Mac OS X) AppleWebKit/601.1.46 (KHTML, like Gecko) Version/9.0 Mobile/13F69 Safari/601.1\n"
+ "Mozilla/5.0 (iPhone; CPU iPhone OS 7_0 like Mac OS X) AppleWebKit/537.51.1 (KHTML, like Gecko) Version/7.0 Mobile/11A465 Safari/9537.53 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)\n"
+ "Mozilla/5.0 (iPhone; CPU iPhone OS 7_0_2 like Mac OS X) AppleWebKit/537.51.1 (KHTML, like Gecko) CriOS/30.0.1599.12 Mobile/11A501 Safari/8536.25 MicroMessenger/6.1.0\n"
+ "Mozilla/5.0 (iPhone; CPU iPhone OS 11_3 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.0 Mobile/15E148 Safari/604.1\n"
+ "Mozilla/5.0 (iPhone; CPU iPhone OS 10_2_1 like Mac OS X) AppleWebKit/602.4.6 (KHTML, like Gecko) Mobile/14D27 MicroMessenger/6.5.5 NetType/WIFI Language/zh_CN\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}