$re = '/(.*)\/([^.]+)(.*)/i';
$str = 'https://776fd56e08b58f28e0c93aa2aedd9b8ab5c11431.googledrive.com/host/0B_8okaqRyPERVlM0OVVCS29TVzQ/1706-16902-22220.png';
$subst = "$1$2_thumbnail$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;