$re = '/(?:([98])\1\1)/m';
$str = '88839182
99923213
98939117 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);