#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:([98])\1\1)).*$"
Local $sString = "88839182 " & @CRLF & _
"99923213" & @CRLF & _
"98939117" & @CRLF & _
"34353454" & @CRLF & _
"88566666" & @CRLF & _
"88823243" & @CRLF & _
"9995" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")