package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`".*?"|\S+`)
var str = `distance Dallas "New York City"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}