import Foundation
let pattern = #"^[0-9]{0,7}([\.,][0-9]{1,2}|[0-9]{0,2})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
.01
1
1.01
0
1234567.89
Unmatch type:
.012
1.098
123.456
,01
1
1.01
0
1234567,89
1234567,.89
Unmatch type:
,012
1,098
123,456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)