$re = '/^(?!0+$)(?P<id>\d+)$/m';
$str = '123
00
010203
000000001
00000
0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);