$re = '/(\b\w*(\w)(?=\2)\w*\b)/';
$str = 'word accomplish seen food dinner lunch ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);