$re = '/(\[[\.\-\w]+\])/i';
$str = 'Salut, j\'insère mon petit bloc [test] et il a été capturé';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);