package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<BASE\s+href="(.*?)"`)
var str = `<BASE href="http://whatreallyhappened.com/">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}