import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.*(?:(?:id=\"(?'id'\\w+)\")|(?:class=\"(?'class'\\w+)\")))";
final String string = "<div id=\"content\" class=\"container\">\n\n\n\n\n"
+ "<div id=\"fb-root\" class=\" fb_reset\"><div style=\"position: absolute; top: -10000px; height: 0px; width: 0px;\"><div></div></div><div style=\"position: absolute; top: -10000px; height: 0px; width: 0px;\"><div><iframe name=\"fb_xdm_frame_http\" frameborder=\"0\" allowtransparency=\"true\" allowfullscreen=\"true\" scrolling=\"no\" id=\"fb_xdm_frame_http\" aria-hidden=\"true\" title=\"Facebook Cross Domain Communication Frame\" tabindex=\"-1\" src=\"http://staticxx.facebook.com/connect/xd_arbiter/r/Lcj5EtQ5qmD.js?version=42#channel=fbbb4ebb7e166c&origin=http%3A%2F%2Fwww.teleman.pl\" style=\"border: none;\"></iframe><iframe name=\"fb_xdm_frame_https\" frameborder=\"0\" allowtransparency=\"true\" allowfullscreen=\"true\" scrolling=\"no\" id=\"fb_xdm_frame_https\" aria-hidden=\"true\" title=\"Facebook Cross Domain Communication Frame\" tabindex=\"-1\" src=\"https://staticxx.facebook.com/connect/xd_arbiter/r/Lcj5EtQ5qmD.js?version=42#channel=fbbb4ebb7e166c&origin=http%3A%2F%2Fwww.teleman.pl\" style=\"border: none;\"></iframe></div></div></div>\n\n"
+ "<div id=\"showOverview\" itemscope=\"\" itemtype=\"http://schema.org/Movie\">\n"
+ " \n"
+ " <div id=\"showPhoto\">\n"
+ " <a href=\"http://media.teleman.pl/photos/Zabojcza-Bron-4-1998.jpg\"><img src=\"http://media.teleman.pl/photos/470x265/Zabojcza-Bron-4-1998.jpg\" width=\"470\" height=\"264\" alt=\"Zabójcza broń 4\" itemprop=\"image\"></a>\n"
+ " <a id=\"playTrailer\" href=\"http://www.youtube.com/watch?v=7cpig7OhI98\" itemprop=\"trailer\" target=\"_blank\" onclick=\"playTrailer(event, '7cpig7OhI98')\">► Zobacz zwiastun</a>\n"
+ " </div>\n"
+ " \n\n"
+ " <div>\n"
+ " \n"
+ " <h1 class=\"title\" itemprop=\"name\">Zabójcza broń 4</h1>\n"
+ " \n"
+ " \n"
+ " \n"
+ " <a class=\"movieRank filmwebRank\" href=\"http://www.filmweb.pl/film/Zab%C3%B3jcza+bro%C5%84+4-1998-203\" title=\"zobacz stronę tego filmu w serwisie Filmweb.pl\" target=\"_blank\"><strong>7.4</strong>/10</a>\n"
+ " <a class=\"movieRank imdbRank\" href=\"http://www.imdb.com/Title?Lethal+Weapon+4+%281998%29\" title=\"zobacz stronę tego filmu w bazie IMDb (ang.)\" rel=\"nofollow\" target=\"_blank\"><strong>6.6</strong>/10</a>\n"
+ " <script>\n"
+ "(function(d, s, id) {\n"
+ " var js, fjs = d.getElementsByTagName(s)[0];\n"
+ " if (d.getElementById(id)) return;\n"
+ " js = d.createElement(s); js.id = id;\n"
+ " js.src = \"http://connect.facebook.net/pl_PL/sdk.js#xfbml=1&version=v2.5&appId=196985250356550\";\n"
+ " fjs.parentNode.insertBefore(js, fjs);\n"
+ "}(document, 'script', 'facebook-jssdk'));\n"
+ "</script>\n"
+ "<div class=\"fb-like fb_iframe_widget\" data-href=\"http://www.teleman.pl/tv/Zabojcza-Bron-4-753804\" data-send=\"false\" data-layout=\"button_count\" data-width=\"100\" data-show-faces=\"false\" data-font=\"arial\" data-action=\"recommend\" fb-xfbml-state=\"rendered\" fb-iframe-plugin-query=\"action=recommend&app_id=196985250356550&container_width=100&font=arial&href=http%3A%2F%2Fwww.teleman.pl%2Ftv%2FZabojcza-Bron-4-753804&layout=button_count&locale=pl_PL&sdk=joey&send=false&show_faces=false&width=100\"><span style=\"vertical-align: bottom; width: 74px; height: 20px;\"><iframe name=\"f37240bcde00fac\" width=\"100px\" height=\"1000px\" frameborder=\"0\" allowtransparency=\"true\" allowfullscreen=\"true\" scrolling=\"no\" title=\"fb:like Facebook Social Plugin\" src=\"https://www.facebook.com/v2.5/plugins/like.php?action=recommend&app_id=196985250356550&channel=http%3A%2F%2Fstaticxx.facebook.com%2Fconnect%2Fxd_arbiter%2Fr%2FLcj5EtQ5qmD.js%3Fversion%3D42%23cb%3Df2d3ff71a02584%26domain%3Dwww.teleman.pl%26origin%3Dhttp%253A%252F%252Fwww.teleman.pl%252Ffbbb4ebb7e166c%26relation%3Dparent.parent&container_width=100&font=arial&href=http%3A%2F%2Fwww.teleman.pl%2Ftv%2FZabojcza-Bron-4-753804&layout=button_count&locale=pl_PL&sdk=joey&send=false&show_faces=false&width=100\" style=\"border: none; visibility: visible; width: 74px; height: 20px;\" class=\"\"></iframe></span></div>\n\n"
+ " <h2 class=\"orig-title\">(Lethal Weapon 4)</h2>\n"
+ " \n"
+ " <div id=\"showInfo\">\n"
+ " <div id=\"showMainInfo\">\n"
+ " <span>FILM SENSACYJNY</span> <span class=\"sep\"></span> <span>USA</span> <span class=\"sep\"></span> <span>1998</span>\n"
+ " <span class=\"age-rating age-rating-po16\" title=\"kategoria wiekowa — od 16 lat\">od 16 lat</span>\n"
+ " </div>\n"
+ " \n"
+ " \n"
+ " <table id=\"showMoreInfo\" cellspacing=\"0\">\n"
+ " <tbody><tr><th>Występują:</th><td><a href=\"/osoby/Mel-Gibson-9129\">Mel Gibson</a>, <a href=\"/osoby/Danny-Glover-3554\">Danny Glover</a>, <a href=\"/osoby/Joe-Pesci-2667\">Joe Pesci</a>, <a href=\"/osoby/Rene-Russo-5934\">Rene Russo</a></td></tr>\n"
+ " <tr><th>Reżyseria:</th><td><a href=\"/osoby/Richard-Donner-12055\" itemprop=\"director\">Richard Donner</a></td></tr>\n"
+ " <tr><th>W skrócie:</th><td>Policjanci prowadzą śledztwo w sprawie zabójstw ludzi z azjatyckiej mafii.</td></tr>\n"
+ " </tbody></table>\n"
+ " \n"
+ " \n"
+ " <blockquote class=\"review\">\n"
+ " <em class=\"stars stars_3\"></em>\n"
+ " <span>Jeszcze raz to samo: Mel Gibson i Danny Glover jako nadgorliwi policjanci wikłający się w najbardziej szalone dochodzenia. Cała ekipa nadal w dobrej formie, a pomysłowość speców od efektów specjalnych i układów kaskaderskich najwyższej klasy. Dla amatorów.</span>\n"
+ " <div>Konrad J. Zarębski, <a href=\"http://wyborcza.pl/0,90535.html\" rel=\"nofollow\">Gazeta Telewizyjna</a></div>\n"
+ " </blockquote>\n"
+ " \n"
+ " </div>\n"
+ " <div class=\"clear\"></div>\n"
+ " </div>\n"
+ " <div class=\"clear\"></div>\n"
+ "</div>\n\n\n"
+ "<script>\n"
+ "function playTrailer(e, video_id) {\n"
+ " e.preventDefault();\n"
+ " var iframe = $('<iframe>', {\n"
+ " 'id': 'trailer-player',\n"
+ " 'width': '976',\n"
+ " 'height': '549',\n"
+ " 'src': 'http://www.youtube.com/embed/' + video_id + '?version=3&showinfo=0&rel=0&modestbranding=1&autoplay=1',\n"
+ " 'frameborder': '0',\n"
+ " 'allowfullscreen': ''\n"
+ " });\n"
+ " $('#trailer-player').replaceWith(iframe);\n"
+ " $('#trailer-section').show();\n"
+ " $('body').animate({\n"
+ " scrollTop: $('#trailer-section').offset().top - 10\n"
+ " });\n"
+ "}\n"
+ "</script>\n"
+ "<div class=\"section\" id=\"trailer-section\" style=\"display:none;margin-top:0;margin-bottom:30px\">\n"
+ " <h2>Zwiastun</h2>\n"
+ " <div id=\"trailer-player\"></div>\n"
+ "</div>\n\n\n\n"
+ "<div id=\"sectionShowSched\" class=\"section\">\n"
+ " <h2>Oglądaj w telewizji</h2>\n"
+ " <div id=\"show-sched\">\n"
+ " <table>\n"
+ " <thead>\n"
+ " <tr>\n"
+ " <td>Data</td>\n"
+ " <td>Godzina</td>\n"
+ " <td>Stacja</td>\n"
+ " </tr>\n"
+ " </thead>\n"
+ " <tbody>\n"
+ " \n"
+ " <tr>\n"
+ " <td><span>piątek, 12 sierpnia</span><div>dziś</div></td>\n"
+ " <td><span>0:05</span> </td>\n"
+ " <td>\n"
+ " <a href=\"/program-tv/stacje/TVN?date=2016-08-11#prog12066383\">TVN</a>\n"
+ " \n"
+ " \n"
+ " <span class=\"attr\" title=\"z napisami\">(z napisami)</span>\n"
+ " \n"
+ " </td>\n"
+ " </tr>\n"
+ " \n"
+ " \n"
+ " </tbody>\n"
+ " </table>\n"
+ " \n"
+ " </div>\n"
+ " <div style=\"display:inline-block;margin-left:20px;vertical-align:top\">\n"
+ "<ins class=\"adsbygoogle\" style=\"display:inline-block !important;width:320px;min-height:100px; display: none !important;\" data-ad-client=\"ca-pub-1904398025977193\" data-ad-slot=\"4774107875\" data-color-link=\"2244BB\" qgdsrhu=\"\" hidden=\"\"></ins>\n\n"
+ "<script>\n"
+ "(adsbygoogle = window.adsbygoogle || []).push({});\n"
+ "</script></div>\n"
+ "</div>\n\n\n"
+ "<div class=\"section\">\n"
+ " <h2>Opis</h2>\n"
+ " <p itemprop=\"description\">Detektywi Martin Riggs i Roger Murtaugh wielokrotnie udowodnili, że nie mają sobie równych - wszystkie powierzone im śledztwa zakończyły się sukcesem. Jednakże za każdym razem, kiedy strażnicy prawa starają się zaprowadzić porządek na ulicach Los Angeles, doprowadzają miasto niemal do ruiny. W związku z tym władze policji powierzają Riggsowi i jego partnerowi pracę biurową. Niebawem jednak nadarza się kolejna okazja do poprowadzenia trudnego śledztwa. W ostatnim czasie odnotowano kilka morderstw na ludziach powiązanych z azjatycką organizacją przestępczą. Policjantom przydzielono do pomocy początkującego detektywa Lee Buttersa. Do grupy dołącza również prywatny detektyw Leo Getz. Cała czwórka rozpoczyna pracę nad rozwikłaniem zagadki tajemniczych morderstw. Trafiają na trop okrutnego Wah Sing Ku, członka azjatyckiej mafii, który żyje z przemytu i fałszowania pieniędzy. Tymczasem okazuje się, że narzeczona Riggsa, Lorna, spodziewa się dziecka. Powiększy się także rodzina Rogera, który zostanie dziadkiem. Zanim to nastąpi, partnerzy muszą kolejny raz wykazać się w walce z bandytami.</p>\n"
+ "</div>\n\n\n\n\n\n\n\n\n\n\n"
+ "<div class=\"section section-credits\" id=\"section-credits-cast\">\n"
+ " <h2>Występują <a href=\"javascript:show_more_credits('section-credits-cast')\" class=\"hide\" style=\"display: inline-block;\">(pokaż wszystkich)</a></h2>\n"
+ " <ul class=\"credits\">\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Mel-Gibson-9129\" class=\"photo\"><img src=\"http://media.teleman.pl/faces/crop-32x44/9129.jpg\" width=\"32\" height=\"44\" alt=\"Mel Gibson\"></a>\n"
+ " <a href=\"/osoby/Mel-Gibson-9129\" itemprop=\"actor\">Mel Gibson</a>\n"
+ " <div class=\"ellipsis\">jako Martin Riggs</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Danny-Glover-3554\" class=\"photo\"><img src=\"http://media.teleman.pl/faces/crop-32x44/3554.jpg\" width=\"32\" height=\"44\" alt=\"Danny Glover\"></a>\n"
+ " <a href=\"/osoby/Danny-Glover-3554\" itemprop=\"actor\">Danny Glover</a>\n"
+ " <div class=\"ellipsis\">jako Roger Murtaugh</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Joe-Pesci-2667\" class=\"photo\"><img src=\"http://media.teleman.pl/faces/crop-32x44/2667.jpg\" width=\"32\" height=\"44\" alt=\"Joe Pesci\"></a>\n"
+ " <a href=\"/osoby/Joe-Pesci-2667\" itemprop=\"actor\">Joe Pesci</a>\n"
+ " <div class=\"ellipsis\">jako Leo Getz</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Rene-Russo-5934\" class=\"photo\"><img src=\"http://media.teleman.pl/faces/crop-32x44/5934.jpg\" width=\"32\" height=\"44\" alt=\"Rene Russo\"></a>\n"
+ " <a href=\"/osoby/Rene-Russo-5934\" itemprop=\"actor\">Rene Russo</a>\n"
+ " <div class=\"ellipsis\">jako Lorna Cole</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Jet-Li-21417\" class=\"photo\"><img src=\"http://media.teleman.pl/faces/crop-32x44/21417.jpg\" width=\"32\" height=\"44\" alt=\"Jet Li\"></a>\n"
+ " <a href=\"/osoby/Jet-Li-21417\" itemprop=\"actor\">Jet Li</a>\n"
+ " <div class=\"ellipsis\">jako Wah Sing Ku</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Chris-Rock-4582\" class=\"photo\"><img src=\"http://media.teleman.pl/faces/crop-32x44/4582.jpg\" width=\"32\" height=\"44\" alt=\"Chris Rock\"></a>\n"
+ " <a href=\"/osoby/Chris-Rock-4582\" itemprop=\"actor\">Chris Rock</a>\n"
+ " <div class=\"ellipsis\">jako detektyw Lee Butters</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Steve-Kahan-25903\" class=\"photo\"><img src=\"http://static.teleman.pl/images/nophoto.png?v=1\" data-src=\"http://media.teleman.pl/faces/crop-32x44/25903.jpg\" width=\"32\" height=\"44\" alt=\"Steve Kahan\"></a>\n"
+ " <a href=\"/osoby/Steve-Kahan-25903\" itemprop=\"actor\">Steve Kahan</a>\n"
+ " <div class=\"ellipsis\">jako kapitan Ed Murphy</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Kim-Chan-38257\" class=\"photo\"><img src=\"http://static.teleman.pl/images/nophoto.png?v=1\" data-src=\"http://static.teleman.pl/images/nophoto.png?v=1\" width=\"32\" height=\"44\" alt=\"Kim Chan\"></a>\n"
+ " <a href=\"/osoby/Kim-Chan-38257\" itemprop=\"actor\">Kim Chan</a>\n"
+ " <div class=\"ellipsis\">jako Benny 'Uncle Benny' Chan</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Darlene-Love-15087\" class=\"photo\"><img src=\"http://static.teleman.pl/images/nophoto.png?v=1\" data-src=\"http://media.teleman.pl/faces/crop-32x44/15087.jpg\" width=\"32\" height=\"44\" alt=\"Darlene Love\"></a>\n"
+ " <a href=\"/osoby/Darlene-Love-15087\" itemprop=\"actor\">Darlene Love</a>\n"
+ " <div class=\"ellipsis\">jako Trish Murtaugh</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Traci-Wolfe-15088\" class=\"photo\"><img src=\"http://static.teleman.pl/images/nophoto.png?v=1\" data-src=\"http://media.teleman.pl/faces/crop-32x44/15088.jpg\" width=\"32\" height=\"44\" alt=\"Traci Wolfe\"></a>\n"
+ " <a href=\"/osoby/Traci-Wolfe-15088\" itemprop=\"actor\">Traci Wolfe</a>\n"
+ " <div class=\"ellipsis\">jako Rianne Murtaugh Butters</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Calvin-Jung-24111\" class=\"photo\"><img src=\"http://static.teleman.pl/images/nophoto.png?v=1\" data-src=\"http://static.teleman.pl/images/nophoto.png?v=1\" width=\"32\" height=\"44\" alt=\"Calvin Jung\"></a>\n"
+ " <a href=\"/osoby/Calvin-Jung-24111\" itemprop=\"actor\">Calvin Jung</a>\n"
+ " <div class=\"ellipsis\">jako detektyw Ng</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Damon-Hines-15090\" class=\"photo\"><img src=\"http://static.teleman.pl/images/nophoto.png?v=1\" data-src=\"http://media.teleman.pl/faces/crop-32x44/15090.jpg\" width=\"32\" height=\"44\" alt=\"Damon Hines\"></a>\n"
+ " <a href=\"/osoby/Damon-Hines-15090\" itemprop=\"actor\">Damon Hines</a>\n"
+ " <div class=\"ellipsis\">jako Nick Murtaugh</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Ebonie-Smith-25906\" class=\"photo\"><img src=\"http://static.teleman.pl/images/nophoto.png?v=1\" data-src=\"http://media.teleman.pl/faces/crop-32x44/25906.jpg\" width=\"32\" height=\"44\" alt=\"Ebonie Smith\"></a>\n"
+ " <a href=\"/osoby/Ebonie-Smith-25906\" itemprop=\"actor\">Ebonie Smith</a>\n"
+ " <div class=\"ellipsis\">jako Carrie Murtaugh</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Mary-Ellen-Trainor-7266\" class=\"photo\"><img src=\"http://static.teleman.pl/images/nophoto.png?v=1\" data-src=\"http://media.teleman.pl/faces/crop-32x44/7266.jpg\" width=\"32\" height=\"44\" alt=\"Mary Ellen Trainor\"></a>\n"
+ " <a href=\"/osoby/Mary-Ellen-Trainor-7266\" itemprop=\"actor\">Mary Ellen Trainor</a>\n"
+ " <div class=\"ellipsis\">jako Dr. Stephanie Woods</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Eddy-Ko-38258\" class=\"photo\"><img src=\"http://static.teleman.pl/images/nophoto.png?v=1\" data-src=\"http://media.teleman.pl/photos/crop-32x44/Eddy-Ko.jpg\" width=\"32\" height=\"44\" alt=\"Eddy Ko\"></a>\n"
+ " <a href=\"/osoby/Eddy-Ko-38258\" itemprop=\"actor\">Eddy Ko</a>\n"
+ " <div class=\"ellipsis\">jako Hong</div>\n"
+ " </li>\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Elizabeth-Sung-12615\" class=\"photo\"><img src=\"http://static.teleman.pl/images/nophoto.png?v=1\" data-src=\"http://media.teleman.pl/faces/crop-32x44/12615.jpg\" width=\"32\" height=\"44\" alt=\"Elizabeth Sung\"></a>\n"
+ " <a href=\"/osoby/Elizabeth-Sung-12615\" itemprop=\"actor\">Elizabeth Sung</a>\n"
+ " <div class=\"ellipsis\">jako Hong's Wife</div>\n"
+ " </li>\n"
+ " \n"
+ " </ul>\n"
+ "</div>\n\n\n\n"
+ "<div class=\"section section-credits\" id=\"section-credits-crew\">\n"
+ " <h2>Twórcy <a href=\"javascript:show_more_credits('section-credits-crew')\" class=\"hide\">(pokaż wszystkich)</a></h2>\n"
+ " <ul class=\"credits\">\n"
+ " \n"
+ " <li class=\"credits-item\">\n"
+ " <a href=\"/osoby/Richard-Donner-12055\" class=\"photo\"><img src=\"http://media.teleman.pl/faces/crop-33x44/12055.jpg\" width=\"33\" height=\"44\" alt=\"Richard Donner\"></a>\n"
+ " <a href=\"/osoby/Richard-Donner-12055\">Richard Donner</a>\n"
+ " reżyseria\n"
+ " </li>\n"
+ " \n"
+ " </ul>\n"
+ "</div>\n\n\n\n"
+ "<script>\n"
+ "$(document).ready(function() {\n"
+ " $('div.section-credits').each(function() {\n"
+ " var $this = $(this);\n"
+ " var width = 0;\n"
+ " var containerWidth = $this.width();\n"
+ " $this.find('.credits-item').each(function() {\n"
+ " width += $(this).width();\n"
+ " if (width > containerWidth) {\n"
+ " $this.find('h2 a').css('display', 'inline-block');\n"
+ " return false;\n"
+ " }\n"
+ " });\n"
+ " });\n"
+ "});\n\n"
+ "function show_more_credits(id) {\n"
+ " var el = $(document.getElementById(id));\n"
+ " el.find('.credits').css('height', 'auto');\n"
+ " $(\".credits img[data-src]\").each(function() {\n"
+ " var el = $(this);\n"
+ " el.attr('src', el.attr('data-src'));\n"
+ " });\n"
+ " el.find('h2 a').hide();\n"
+ "}\n"
+ "</script>\n\n\n\n\n\n\n\n\n\n\n"
+ "<div style=\"overflow:hidden;margin-top:30px\">\n"
+ " <div style=\"width:300px;height:250px;float:left\">\n"
+ "<ins class=\"adsbygoogle\" style=\"display:inline-block !important;width:300px;min-height:250px; display: none !important;\" data-ad-client=\"ca-pub-1904398025977193\" data-ad-slot=\"4723729075\" data-color-link=\"2244BB\" qgdsrhu=\"\" hidden=\"\"></ins>\n\n"
+ "<script>\n"
+ "(adsbygoogle = window.adsbygoogle || []).push({});\n"
+ "</script></div>\n"
+ "</div>\n\n\n"
+ "<img src=\"http://static.teleman.pl/images/pixel.gif?show,753804,20160812\" alt=\"\" width=\"0\" height=\"0\" hidden=\"\" style=\"display: none !important;\">\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}