const regex = /^.*?(?=[A-Z]+_)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(?=[A-Z]+_)', '')
const str = `AB73gDf9y::-8auhTHIS_IS_WHAT_I_WANT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}