// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(^|\s)([0-9]{4}|[0-9]{6}|[0-9]{8})(\s|\.|,)[^0-9]").unwrap();
let string = "Dear Customer, OTP to login to SBI Internet banking(Personal) is 12343212. Do not share with anyone. -SBI";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}