using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}\+\d{4})";
string input = @"'{""roomMappings"":{""createdAt"":""2015-04-10T00:32:04+0000"",""channelOffers"":[]}}'";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}