re = /\b[a-z]*?([a-z]{2,}?)\1+[a-z]*?\b/i
str = 'hahahahahah, hihihi, huehue, xixixi, abcdefgefgefg, hurrhurr, ballistics, ballballball, ballerina, ballerinanana'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end