// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xi)([a-z]\s*)?
(
(
[零幺一二两三四五六七八九十百千万点比]
|[零一二三四五六七八九十][ ]
|(?<=[一二两三四五六七八九十])[年月日号]
|(分之)
)+
(
(?<=[一二两三四五六七八九十])[a-zA-Z年月日号个只分万亿秒]
|(?<=[一二两三四五六七八九十]\s)[a-zA-Z]
)?
(?(1)
|(?(5)
|(
[零幺一二两三四五六七八九十百千万亿点比]
|(分之)
)
)+
)
)").unwrap();
let string = "压缩软件七 zip
这是一部 iPhone 四 s
这是一部苹果四 s
我要玩 gta五
索尼相机 mark 五
三星 s 七
数字测试一万三千七百零二
不管三七二十一
九九八十一难
时间测试二零一八年五月二十三号上午十点十分
一万零七十六
百分之三十二点六八
比分测试十七比十六
比分测试三十七比十六
一点一
一点一滴
八九十
一个人一定要
一五八七三六九零
二七九三零一二二
八五三零七四九九
二六一四九七八七
一五九六四八六二
四五六九八七二三
四八六一五九六四
一七八六四五八九
一二三加四五六
九七八六加三三八四
发电站每天发电三万零二十九度电
银行月交易总额七千九百零三亿元
深圳每月平均工资在一万三千元
每月房租要交一千伍佰元
我每月交通费用在四百元左右
本月开销费用是五万一千三百二十八元
如果你中了五千万元奖金会分我一半吗
这个月工资我发了三千五百二十九元
学会了这个技能你至少可以涨薪五千元
我们的会议时间定在九点二十五分开始
上课时间是八点十五分请不要迟到
昨天你九点二十一分才到教室
今天是二零一九年一月三十一号
今年的除夕夜是二零一九年二月四号
这根水管的长度不超过三十五米
四百米是最短的长跑距离
最高的撑杆跳为十一米
等会请在十二点零五分请通知我
二十三点十五分开始
你生日那天我会送你九百九十九朵玫瑰
给我一双鞋我可以跳九十六米远
虽然我们的身高相差三百五十六毫米也不影响我们交往
我们班的最高总分为五百八十三分
今天考试老师多扣了我二十一分
我量过这张桌子总长为一点三七米
乘务员身高必须超过一百八十五公分
这台电脑分辨率为一零二四
手机价格不超过一千五百元
一百零一点二三
一百二十三点一一六
四百五十六点一四七
零点一五九四
三点一四一五
零点一一二二三三
零点一
四万零一点九八七
五十六点八七八
零点零零一二三
零点零零零一
零点九二零一五
九百九十九点零零零一
一万点一二三
六百六十六点五五五
四百四十四点七八九
七百八十九点六六六
零点一二三四五
一点零五六四九
环比上调百分之一点八六
环比分别下跌百分之三点四六及微涨百分之零点七零
单价在三万元的二手房购房个案当中
六月仍有百分之七单价在三万元的房源
最终也只是以总积分一分之差屈居第二
中新网八月二十九日电今日
自六月底呼和浩特市率先宣布取消限购后
仅一个多月的时间里
除了北京上海广州深圳四个一线城市和三亚之外
四十六个限购城市当中
四十一个已正式取消或变相放松了限购
其中包括对拥有一套住房并已结清相应购房贷款的家庭
这个后来被称为九三零新政策的措施
今年有望超三百亿美元
就连一向看多的任志强
近期也一反常态地发表看空言论
这块黄金重达三百二十四点七五克
她出生于八六年八月十八日她弟弟出生于一九九五年三月一日
电影中梁朝伟扮演的陈永仁的编号二七一四九
现场有十二分之七的观众投出了赞成票
随便来几个价格十二块五和三十四点五元和二十点一万
明天有百分之六十二的概率降雨
这是固话零四二一三三四四一一二二
这是手机八六一八五四四一三九一二一
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}