using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<has_quotes>(?:[^,""'\n]*(?:(?<double_quotes>""[^""\n]*"")|(?<single_quotes>'[^'\n]*'))[^,""'\n]*)+)|(?<simple>[^,\n]+)";
string input = @"a'b
abcd,efgh, ijkl
abcd, efgh, ij""k,l"", mnop, 'q,rs't
abcd, efgh, ij""k,l',a""', mnop, 'q,r,s't
abcd, efgh, ij""k,l"", mnop, 'q,rs't
'q, rs't
""'q,rs't, ij""k, l""
""'q,rs't, ij""k""'q,rs't, ij""k, l""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}