import Foundation
let pattern = ##"""
(?xi) # i-flag for caseless, x-flag for comments (free spacing mode)
# 1.) match <select with optional space at the end
<\s*select\s[^>]*?\bname\s*=\s*["']\s*quantity[^>]*>\s*
# 2.) match lazily any amount of options until the "selected"
(?:<\s*option[^>]*>\s*)*?
# 3.) match selected using a lookahead and capture number from value
<\s*option\s(?=[^>]*?\bselected)[^>]*?\bvalue\s*=\s*["']\s*(\d[.,\d]*)
"""##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<select attr="other stuff" name="quantity">
<option value="1" />
<option value="2" selected="selected" />
</select>
....
<select name="quantity" attr="other stuff">
<option selected="selected" value="5" />
<option value="6" />
</select>
....
<select name="quantity" attr="other stuff">
<option value="6" />
<option value="6" />
<option value="6" />
<option value="6" />
<option selected value= " 777.7 " />
<option value="6" />
</select>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)