$re = '/^(?![\W_]+$)(?![0-9]+$)[\w\W]{3,60}$/m';
$str = 'Something like this 6#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);