import re
regex = re.compile(r"([+\-]*[1-9][0-9]?[0-9]?(ne|nw|se|sw|n|s|e|w|NE|NW|SE|SW|N|S|E|W|Ne|Nw|Se|Sw|nE|nW|sE|sW))*", flags=re.IGNORECASE)
test_str = "1Nw-2sE7nE6Sw"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")