import re
regex = re.compile(r"(?<=\"NULL\",\"0\",\"0\",\"0\",\",\",\"1\",\",)(?:\"([^\"]+)\",?)+(?=,\"D\$\")", flags=re.MULTILINE)
test_str = ("\"apple\",\"NULL\",\"0\",\"0\",\"0\",\",\",\"1\",\",\"fruit\",\"red\",\"sweet\",\"D$\",\"object\"\n"
"\"horse\",\"NULL\",\"0\",\"0\",\"0\",\",\",\"1\",\",\"animal\",\"large\",\"tail\",\"D$\",\"object\"\n"
"\"Los Angeles\",\"NULL\",\"0\",\"0\",\"0\",\",\",\"1\",\",\"city\",\"California\",\"smoggy\",\"entertainment\",\"D$\",\"location\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")