$re = '/(?<code>\d+(?:A\d+)?(?:,\d+)*;)/';
$str = '4A2;
2A3,3;
18A7,4,5;
19A1; 8A5,2;
20A2; 21A1,5,4;
4B1.2
4B1 2 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);