import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*#([\\p{Pc}\\p{N}\\p{L}\\p{Mn}]{1,50})$";
final String string = "#validhashtag\n"
+ "#valid_hashtag\n"
+ " #validhashtag_with_space_before_or_after\n"
+ "#valid_hashtag_chars_öÖäÄüÜß\n\n"
+ "ipsum#notvalid //Not valid: Connected to Word\n"
+ "http://google.com/#results //Not valid: Same as above\n"
+ "#not-valid\n"
+ "#not!valid";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}