$re = '/^(\d)(\d)\2+\1$/m';
$str = '7007
1551
3993
5115
9889
1232 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);