$re = '/([^|]*)\|.*/';
$str = 'value1%7Cvalue2=%20a%20|value3"';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;