re = /"[^"]*"|'[^']*'|(\w+)/
str = '\'single\' The \'quick \' brown \'fox\' jumps "over" the "lazy" dog. "The quick brown fox jumps over the lazy dog" The quick brown fox jumps over the lazy dog. "The quick brown fox jumps over the lazy dog" The quick brown fox jumps over the lazy dog. "The quick brown fox jumps over the lazy dog" The quick brown fox jumps over the lazy dog. "The quick brown fox jumps over the lazy dog" The quick brown fox jumps over the lazy dog. "The quick brown fox jumps over the lazy dog" The quick brown fox jumps over the lazy dog. "The quick brown fox jumps over the lazy dog".'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end