$re = '/^([m]|[k])$/i';
$str = 'mi
km
mi km
mikm kmmi
hhgkmgj
k
m
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);