import re
regex = re.compile(r"\[link\](.*?),(.*?)\[\/link\]")
test_str = ("This is a page description that will contain multiple link markups such\n"
" as [link]http://url.com,this[/link] and [link]http://url.com,this too[/link]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")